Bug en WordPress 2.8 al actualizar plugins automáticamente

Luego de actualizar la versión de este blog a la última versión liberada hace unos días (tiene mejoras interesantes al UI), encontré un problema al tratar de actualizar o instalar plugins desde el Dashboard. Arrojaban este error:

Incompatible archive PCLZIP_ERR_BAD_FORMAT (-10) : Invalid archive structure

El problema es un bug en esta novísima versión. Para solucionarlo, hay que reemplazar el archivo wp-includes/http.php con la versión corregida, que se puede encontrar aquí. Si no quieres meterle mano a tu instalación, puedes esperar algunos días hasta que liberen un nuevo release corriendo esto.

UPDATE: Ya fue reportado el bug.

3 thoughts on “Bug en WordPress 2.8 al actualizar plugins automáticamente”

  1. olle, yo tengo un problema igual, pero me sucede al subir un theme…

    el error que me aparece ese este

    “Archivo incompatible PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature”

    estoy desesperado no encuentro niguna solucion, espero y me puedas ayudar

    saludos

  2. @mario: Primero prueba que el archivo del theme lo puedas unzipear en tu máquina, quizá no sea problema del WP sino del mismo archivo (podría estar corrupto). En caso no encuentres problemas, te recomiendo que lo vuelvas a zipear tu mismo.
    Estas usando la última versión de WP (2.8.2) verdad?

Leave a Reply

Your email address will not be published. Required fields are marked *

Are you human? *